Inicio > linux, sistemas operativos > Montar VHD Existente en Citrix Mediante NFS

Montar VHD Existente en Citrix Mediante NFS

La semana pasada nos toco reemplazar un disco en un servidor HP, el cual estaba dando problemas de escritura, bueno cuento corto había información que por algúna razón no se respaldo y tuvimos que recuperarla, teníamos el servidor funcionando en producción, por lo que no podíamos desconectarlo, tampoco contábamos con una maquina en la cual instalar Citrix y poder montar nuestro disco, solo contábamos con un viejo Pentium 4 sin soporte para virtualización, por lo que bajamos un LiveCD de Linux (Ubuntu 11.x) y iniciamos el sistema.
Como sabemos Citrix crea una partición de tipo LVM, por lo que debimos instalar el soporte en Ubuntu mediante:

sudo apt-get install lvm2
Luego montamos el dispositivo mediante los siguientes comandos
Sudo vgdisplay ( Sacamos el nombre del volumegroup)
sudo vgchange -ay /dev/VolGroup01 (El nombre de nuestro volumen, obtenido con el comando anterior)

sudo lvdisplay (Sacamos el nombre del dispositivo lógico)

Montamos el filesystem:

sudo mount /dev/VolGroup01/LogVol03 /mnt

Luego de esto vemos la partición /mnt y nos encontramos con el archivo .vhd que nos genera Xen Server.

Siguiente Paso

Configurar un servidor NFS en nuestra máquina para poder montarlo mediante Citrix Xen Center, para eso seguiremos la siguiente guía http://ubuntuforums.org/showthread.php?t=249889 y dejaremos compartido el directorio /mnt

nfs citrix

nfs citrix

Una vez montando nuestro servidor, nos vamos a Xen Center y Creamos un Storage basado en NFS, en mi caso no detecto que existieran SR por lo que me creo un directorio en /mnt al cual movi el archivo vhd mediante.

mv disco.vhd storage_creadopor_xen

Usamos el boton SCAN de xen y ya tenemos el disco en funcionamiento sin tener que intervener el servidor.

Cualquier duda me comentan, ya que está bastante resumido

Referencias:
http://johnsofteng.wordpress.com/2010/01/28/ubuntu-livecd-mount-lvm2-fs/
http://ubuntuforums.org/showthread.php?t=249889

Anuncios
  1. junio 7, 2012 en 3:55 pm

    amigos se que no tiene ver con el tema, pero si de citrix ocupo ayuda urgente
    mi problema es que instale un programa que ocupa conexion con SQL server pero cuando cambio de usuario me vuelve a pedir la informacion de conexion con SQL no borra la carpte del sistema en regedit pero si la infor de adentro por lo que se tiene que volver a configurar la conexion. alguien sabe como solucionar eso mi correo meguia@seer.com.mx

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: